Thomas Woelfers Baustatik Blog

Baustatik-Software und was sonst des Weges kommt

Ärgerlicher Fehler im Setup von Baustatik

Folgendes ist passiert: Seit Version 1.17 trägt das Installationsprogramm der Baustatik in der Windows-Registry einen Pfad ein. Dabei handelt es sich um den Pfad, unter dem die Software im System installiert wurde. Der Grund dafür ist der, das separate Lizenz-Installer die Installation finden können und die Lizenz-Datei an die richtige Stelle kopieren können.

Dieser Pfad wird im gleichen Ast der Registry gespeichert, in dem auch die älteren Programme diese Information ablegen. Blöderweise wird dieser Ast beim deinstallieren der Software ebenfalls vom Rechner entfernt. Dummerweise wird dabei gleich der ganze Ast mit entfernt und nicht nur der eine Eintrag. Das hat nur eine dumme Nebenwirkung: Die "alten" Programm laufen danach nicht mehr, bzw. können nicht mehr gestartet werden.

Auch das wäre noch weiter kein Beinbruch - es passiert ja nicht so besonders oft, das die Baustatik deinstalliert wird. Sollte man meinen - nur ist das leider nicht so: Jedesmal wenn ein Update der Baustatik installiert wird, entfernt das Installationsprogramm zunächst die bereits installierte Version.

Mit anderen Worten: Durch das installieren eines Updates für die Baustatik können die "alten" Programme nicht mehr gestartet werden. Sorry - Mea Culpa.

Glücklicherweise ist zumindest die Lösung des Problems einfach: Es reicht aus, einmal von der Installations-CD die "Programme" zu installieren: Das trägt die Pfade wieder ein, und die Programme laufen dann auch wieder.

Das Problem ist leider erst heute ans Licht gekommen: Diesen Registry-Eintrag gibt es erst seit Version 1.17, und damit trat das Problem dann beim installieren aufs Update mit der Version 1.18 zum ersten Mal auf. Jeder, der von 1.17 auf 1.18 wechselt muss also danach außerdem einmal das Setup-Programm für die "alten" Programme laufen lassen.

Außerdem ist der Fehler natürlich auch in allen 1.18 Setups drin, die gestern oder heute Vormittag runtergeladen wurden. (Die zur Zeit auf dem Server liegende Version hat das Problem nicht mehr.). Wehr also gestern oder heute eine 1.18er Version runtergeladen hat, der bekommt das gleiche Problem dann beim installieren des nächsten Updates....

Kann mich nur entschuldigen....

Comments are closed