Thomas Woelfers Baustatik Blog

Baustatik-Software und was sonst des Weges kommt

Hilfreich oder verwirrend: Der Copy-Button

Mein Bruder hat hier schon über den Support für die Zwischenablage (Clipboard) in unseren aktuellen Programmen geschrieben, und auch darauf hingewiesen das in dieser Richtung mehr zu erwarten ist. Zu den angesprochenen 'intelligenteren' und 'komfortableren' Möglichkeiten werde ich zu einem späteren Zeitpunkt noch genug schreiben - hier gehts jetzt erstmal einfach nur um das 'normale' Clipboard, und über eine kleine Aergerlichkeit die mir heute im Faltwerksprogramm aufgefallen ist.

Bei den jetzt verfügbaren Programmen ist es so, das Sie zwei 'Kopieren' Buttons haben. Der eine kopiert Text, der andere kopiert eine Graphik in die Zwischenablage. Man kann als danach entweder Text oder aber Graphik woanders einfügen.

Bei den neuen Programmen ist das anders. Zum einen kann man da neben Text und Graphik auch noch andere Formate einfügen (HTML, nach Word, nach Excel, in verschiedene Graphikprogramme...) und natürlich kann man auch einfach Teile der Struktur in die Zwischenablage kopieren.

Das 'einfügen' funktioniert dann im Programm selbst - man bekommt eben eine Kopie der markierten Teile des Bauwerkes - aber auch in anderen Programmen. Was dort eingefügt wird, ist von den 'anderen Programmen' abhängig. In Excel fügen wir eben Zellen ein, in Notepad Text und in Paint eben eine Graphik.

Und da geht der Aerger los: Normalerweise würde man erwarten, das der 'Kopieren' Button in der Werkzeugleiste ausgeschaltet ist, wenn im Tragwerk momentan keine Elemente ausgewählt sind. Denn: Ist nichts ausgewählt, kann auch nichts in die Zwischenablage kopiert werden. Das stimmt aber so nicht mehr - denn Sie können IMMER das momentan angezeigte Bild kopieren. Dazu muss nichts ausgewählt sein. Das muss so sein, denn ansonsten könnte man ja nur Graphiken kopieren in denen immer 'ausgewählte' Strukturelemente vorhanden sind... Das will man ganz sicher nicht.

Das bedeutet, der 'Copy' Button ist immer 'an'. Nun würde man erwarten das der 'Einfügen' Button 'an' geht, nachdem man einmal auf 'Copy' gedrückt hat. Das passiert aber auch nicht immer. Denn wenn nichts im Bauwerk ausgewählt ist, dann wird auch nur eine Graphik in die Zwischenablage kopiert. Die Graphik kann man aber eben nur in einem Malprogramm wieder einfügen - nicht im Faltwerk...

Ergebnis: Wenn man nichts ausgewählt hat ist der 'Kopieren' Button trotzdem aktiviert - aber wenn man dann draufdrückt wird der 'Einfügen' Button trotzdem nicht aktiv.

Sobald man das ein paarmal gemacht hat ist das schon ok - aber ich glaube, ich muss mich da trotzdem erst dran gewöhnen.

Comments are closed