Thomas Woelfers Baustatik Blog

Baustatik-Software und was sonst des Weges kommt

"Interessantes" Problem beim installieren von Software

Bin heute mit einem Kunden über ein "interessantes" Problem beim installieren der Baustatik gestolpert - das aber mit Sicherheit auch bei anderen Installationsprogramm auftreten wird. Im wesentlichen lief es darauf hinaus, das die Installation fast vollständig durchgeführt wurde, aber dann am Ende doch abgebrochen und rückgängig gemacht wurde. Mit ein bisschen Nachforschung gab es folgende Fehlermeldung:

Das Protokoll für die Quelle Baustatik Installer kann nicht geöffnet werden. Möglicherweise haben Sie keinen Schreibzugriff. --> Die Schnittstelle ist unbekannt.

Nun ist es so, das wir einfach den Microsoft Systems Installer (MSI) verwenden: Wir haben keinerlei Einfluss auf die angezeigten Fehlermeldungen und sonstige Ereignisse - das wird komplett von Windows erledigt. Mit Hilfe des Kunden war es dann aber möglich, die eigentliche Ursache des Problems herauszufinden: Auf dem betroffenen Rechner lief der Ereignisprotokoll-Dienst nicht.

Das Ereignis-Protokoll ist eine Datenbank in der Windows "wichtige" Ereignisse protokolliert. Dazu gehören unter anderem An- und Abmeldungen und auch Installationsvorgänge. Damit das Ereignisprotokoll "geht" muss der zugehörige Dienst laufen - und das war auf dem betroffenen Rechner nicht der Fall. Das ist aber eher ungewöhnlich: Von Haus aus läuft dieser Dienst immer, und ich kenne auch kein Programm das ausgerechnet diesen Dienst ausschaltet - das macht nämlich einfach keinen Sinn. Schaltet man den Dienst jedenfalls wieder an, läuft der Installer auch durch.

Dann trat beim Kunden aber ein anderes Problem auf, das überhaupt nichts mit der Baustatik zu tun hat: Man _konnte_ diesen Dienst nicht starten. Beim versuch das zu tun, ergab sich folgende Fehlermeldung:

ERROR_WMI_INSTANCE_NOT_FOUND
4201 The instance name passed was not recognized as valid by a WMI data provider
.

Dabei scheint es sich um ein Problem zu handeln, das bei korrumpierten Windows-Installationen auftritt. Den Grund dafür konnte ich nicht herausfinden (es scheint diverse zu geben) - aber es gibt zumindest einen recht umfangreichen Thread, in dem Lösungen beschrieben werden, die bei betroffenen geholfen haben. Der ist hier.

Es wäre zwar schön den eigentlichen Grund herauszufinden - aber wenn es zumindest eine Problemlösung gibt, ist das wohl besser als nichts...

Comments are closed