Thomas Woelfers Baustatik Blog

Baustatik-Software und was sonst des Weges kommt

Problem mit dem Update behoben

Der seit gestern Nachmittag gesperrte Download-Bereich ist wieder verfügbar, und auch die automatischen Updates werden nun wieder heruntergeladen. Das Problem war “merkwürdig”….

Mit dem gestern veröffentlichten Update der Baustatik trat folgendes Problem auf: Nachdem das Update installiert war, “fehlte” der TimeServer – die Datei war einfach nicht mehr auf dem Rechner vorhanden. Wer das Update gestern heruntergeladen hat, kann das Problem allerdings einfach lösen: Man muss “DIE Anwendungen” über die Systemsteuerung einmal deinstallieren, und dann einfach nochmal installieren – danach ist der TimeServer wieder da.

Mit dem Update das zur Zeit im Download-Bereich liegt, tritt das Problem erst gar nicht auf.

Stellt sich die Frage: Was war passiert?

Kurze Antwort: Eigentlich nichts. Das Installationsprogramm ist so ungefähr der einzige Teil an der Baustatik, der sich für dieses Update nicht (wesentlich) geändert hatte.

Trotzdem gab es aber ein Problem – nur war das eigentlich kein neues: Das Installationsprogramm hat in einem bestimmten Kontext noch nie richtig funktioniert, nur hat das nie jemand bemerkt – zumindest nicht bis gestern.

Wir liefern seit Jahren immer 2 Versionen des Baustatik-Installationsprogrammes aus: Die “komplette Version” und die “Version für automatische Updates”. Die “komplette” Version enthält dabei diverse Systemvorraussetzungen (wie zum Beispiel das .NET Framework und die VC++ Laufzeitbibliothek), die “Update” Variante nicht – denn die Systemvorraussetzungen ändern sich nicht und sind bei einem “Update” ja bereits vorhanden. Vorteil: Die “update” Variante ist ca. 100 MB kleiner.

Hat man nun einmal die “komplette” Version installiert (entweder von der CD, oder über die manuell heruntergeladene Variante) und installiert danach nur noch die Updates – und das tun praktisch alle Kunden – dann tritt der Fehler erst gar nicht auf. Installiert man aber eine “komplette” Version irgendwann nachdem schon mal eine solche Version installiert worden war, dann tritt der Fehler auf, und der “TimeServer” wird nicht richtig installiert.

Wie gesagt: Hat bisher niemand bemerkt – zumindest nicht in einem Umfang, der uns dazu drängte weitere Untersuchungen vorzunehmen.

Und da kommt dann die letzte Version ins Spiel, denn die braucht wegen der Änderung an unserem Entwicklungssystem neue Systemvorraussetzungen. Und darum gibt es bei genau dieser Version auch keine Unterscheidung zwischen dem “Update” und dem “komplette” Paket: Man bekommt, egal wie man drankommt – also auch über die automatischen Updates - , immer die “komplette” Variante. Und wurde die installiert… TimeServer weg. Und das ist dann gestern gehäuft passiert.

Der Fehler sollte nun behoben sein, und das Problem sollte nicht länger auftreten. Sorry für die Störung …

Comments are closed